Solusi Error Cannot Adopt OID in xxx-SNMP-xxx

Belum lama coba install composer di komputer lama yang masih terinstall ubuntu 14.04. Setelah di update dan menginstall composer dengan perintah

curl -sS https://getcomposer.org/installer | sudo php — –install-dir=/usr/local/bin –filename=composer

setelah mengetik curl composer gagal terus dengan error “Cannot adopt OID in xxx-SNMP-xxx“ banyak sekali. Awalnya bingung, baru nemu error seperti ini. Saya coba curl tanpa install-dir berjalan lancar. Lalu ketika saya ketik perintah php di console muncul error yang sama. Ternyata PHP nya bermasalah.

Browsing, dan akhirnya nemu stackoverflow. Yep solusi programmer kadang dan hampir selalu nemu di stackoverflow [http://stackoverflow.com/questions/33109933/running-php-via-command-line].

Perintahnya cukup menginstall snmp atau meremove php5-snmp ya 🙂

sudo apt-get install snmp

atau

sudo apt-get remove php5-snmp

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.